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Office of Administrative Hearings 

Rules Division 

Template Documentation 

The Rules Division within the Office of Administrative Hearings has created a Microsoft Word Macro 
Enabled Template that Rulemaking Coordinators can use to facilitate the Rulemaking process. The OAH 
Agency Rules Template contains formatting styles and various utilities that will assist the coordinators as 
they draft and modify rules. The template was developed using Microsoft Word 2016 and should function 
properly in Microsoft Word 2010 or higher. 
The template was developed to assist Rulemaking Coordinators create a document that adheres to the 
requirements set out in 26 NCAC 02C .0108 General Format Instructions. Within the template, there are 
utilities that allow the user to: pull a rule from the OAH website and insert it directly into your document; 
apply various formatting styles to the text within a document; insert auto text for the various Introductory 
Statements required for the submission of a rule; and various other functionality to make the process 
simpler. 

DOWNLOADING THE OAH AGENCY RULES TEMPLATE 
The OAH Agency Rules Template can be downloaded from the "Information For Rulemaking 
Coordinators" section on the OAH website (http://www.oah.nc.gov). To access this section from the OAH 
website, click on the Rules Division menu and then click on the "Information For Rulemaking 
Coordinators" link. 

 
After clicking the “Information For Rulemaking Coordinators” link, scroll down until the Agency Rule 
Template section is visible.   

 

http://reports.oah.state.nc.us/ncac/title%2026%20-%20administrative%20hearings/chapter%2002%20-%20rules%20division/subchapter%20c/26%20ncac%2002c%20.0108.html
http://www.oah.nc.gov/
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Chrome 

Right click on the "Rule Template" Link and select the "Save Target As" menu item (Internet Explorer) 
or the "Save Link As" menu item (Chrome). 
 

 
 
The easiest implementation of the Template is to save the template to the user’s desktop. This can be 
accomplished by clicking the “Save As” option and then select Desktop and press the Save Button. It is 
imperative that you leave the Template named “OAH Agency Rules Template.dotm”. Various 
functionality within the Template requires the standardized naming. 

 
Once the Template has been saved to the Desktop, open the Template by Right Clicking on the 
Template Icon and selecting Open. The first time the Template is opened, the user will be prompted 
to Enable the Template. Once the Enable button has been pressed, the user can close the Template. 
This is only done the first time the template is opened. 
It is also possible to store the OAH Agency Rules Template in either the default Word User or Workgroup 
template locations. This subject is not covered in this documentation but additional information about 
template locations is discussed in this blog posting which is applicable for Microsoft Word 2010 and 
higher: http://www.addbalance.com/word/workgrouptemplates.htm. The instructions in this document 
assume that the template is stored on the user’s desktop. 
  

Internet Explorer Chrome 

http://www.addbalance.com/word/workgrouptemplates.htm
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CREATING A DOCUMENT BASED ON THE OAH AGENCY RULES TEMPLATE 
To use the template, double click on the Template Icon on the Desktop. A new document based on the 
template will be created. An OAH tab will be added to the Microsoft Word Ribbon as can be seen below: 

 

The OAH Tab contains several groups. To allow commonly used Word functionality to be performed 
without the user having to select another Microsoft Office Ribbon tab, several standard Microsoft Office 
Groups have been included on this tab. They are: 

• Clipboard 
• Font 
• Editing 

The buttons in these groups perform in the same way as the buttons on the Standard Word Ribbon and 
will not be discussed further here except to mention that changes to existing rules should be made using 
the underline and strikethrough font attributes – which are available in the Font Group. Language added 
should be underlined and language removed from an existing rule should be struck through. 

FORMATTING GROUP 

 
OAH Rule Formatting Menu 
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The OAH Rule Formatting dropdown menu displays the acceptable formatting options. The menu is 
divided to categorize each option. The Style names are displayed in the left column and a description of 
the styles and enumerations are displayed in the right column. The first three sections contain the three 
acceptable text options. The fourth section displays the standard language options for History Notes. The 
fifth section displays less frequently used styles. To apply the applicable formatting (style), select the text 
to be formatted and click the appropriate menu item. No text will be typed; this menu only applies 
formatting to the selected text. 
Clear Formatting Button 
If you need to “reset” the paragraph and start over, click the Clear Formatting option to remove all 
formatting from the selected text.  
Select Style Dropdown 
The Select Style dropdown menu displays all formatting styles used by OAH. This dropdown may be 
more efficient for users that are familiar with OAH rule formatting. The style of the currently selected text 
can be changed by clicking the dropdown arrow and selecting the applicable style. 

 
The dropdown shows the available rule formatting styles. For styles to be correctly applied to the text, 
the only the two methods of applying styles provided on the OAH tab should be used.  The Word 
styling functionality available on the "Home Tab" may result in underlined, stricken, bolded or 
italicized formatting being lost when a style is applied.   
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Paragraph Center Button 
This menu item simply centers the selected text. 

AUTO FORMAT GROUP 

 
The Auto Format Group is another way to format text. To use this option OAH styles must first be applied 
to the text. The right and left arrow buttons change the style of the text at the location of the curser to the 
next or previous style. For example, when drafting a new rule with a list, type the first paragraph of the 
rule and press enter. This creates a new paragraph in the “Paragraph” format.  

 
To change the style to the Item level, select the right arrow on the Listing line and the style will be changed. 

 
Click the right arrow again to format the text as a Sub-Item level. 

 
To return to the Item style click the left arrow button on the listing line. 
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TEXT GROUP 

 
The Text Group provides menu choices that insert introductory statements into a document or insert an 
entire Chapter, Subchapter, or rule from the OAH online Administrative Code. This group also provides 
an option to insert a document from a file. 
Proposed Intros and Permanent Intros Drop Down Menus 
The Proposed Intros and the Permanent Intros dropdowns display text options for introductory statements. 
Selecting a menu item from the dropdown list inserts the introductory statement at the location of the 
cursor in the document. A blank line is inserted after the introductory statement. The inserted text will be 
styled according to the Rule Formatting guidelines. 
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Insert Rule Menu 
Copy and paste may cause complications in a Word document. Styles may also complicate how the copy 
and paste function works and how it impacts the document. It is suggested that the Insert Rule functions 
are always used to avoid the complications caused by copy and paste. 
The Insert Rule Menu currently has two options. The Insert Rule from Code option retrieves the rule(s) 
from the OAH website and inserts it into the document. The Insert Rule from File will insert a file stored 
on a computer or network. 

Insert Rule from Code 
Upon clicking the Insert Rule from Code option, the Insert OAH Rule dialog box will be presented.   

 
The Insert Rule from Code window allows you to insert an individual rule, all rules contained in a 
SubChapter, or all rules contained in a Chapter. The operator should type a valid Title, Chapter, 
SubChapter and Rule number and press the Okay Button. To insert a specific rule, the Title, Chapter, 
SubChapter (if applicable) and rule number must be entered. To insert a Chapter, the Title and Chapter 
information must be entered. To insert a SubChapter, the Title and SubChapter fields must be entered. If 
the rule(s) exist, the text of the currently published rule(s) in the online NC Administrative Code will be 
inserted into the document. The Title and Chapter/SubChapter numbers that are only a single digit, must 
be preceded by a zero. 
IMPORTANT: The Insert Rule function inserts the text currently published in the NC Administrative 

Code. If a different version of the rule is in publication, pending Rules Review 
Commission action or pending Legislative Review, the text of that version of the rule 
will not be inserted. 
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Insert Rule from File 
The Insert Rule from File option opens the Insert File dialog box so the file can be located and inserted. 

 

 

UTILITIES GROUP 

 
OAH rulemaking guidelines do not allow agencies to submit rules that contain auto numbered enumerated 
lists or Microsoft Word revision marks (tracking). OAH recognizes that these features can be beneficial 
during the rule drafting process, however, they should be removed prior to submitting rules to OAH. 
Remove AutoNumber Button 
The Microsoft Word auto number feature automatically alters the indention level and the wrapping 
structure of the text. Therefore, when a document is created or opened in the OAH Agency Rules 
Template, the auto number feature in Word is disabled. Rules that were already in the rulemaking process 
prior to the introduction of the OAH Agency Rules Template may contain auto numbered lists. For this 
reason, a Remove AutoNumber feature is included on the toolbar that converts auto numbered lists to 
standard enumerated text. When this option is selected, there is not a utility to revert the text back to an 
auto number format. 
Tracking To Text Button 
The use of "tracking" may create complications when OAH processes rules for publication in the NC 
Register and Administrative Code. For this reason, rules should not be submitted to OAH with “tracking”. 
The Tracking to Text feature converts “tracking” to underlining and strikethrough font attributes in the 
document. Once “tracking” has been converted to text the editorial information regarding when changes 
were made and by whom will be lost from the document. 
NOTE: There can be a great deal of complexity in documents containing “tracking”, therefore, it is 

recommended that after running this utility the agency staff carefully review the document to 
ensure that the revisions are accurately represented. 
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Text to Tracking Button 
The rules and notices returned to the agency by OAH will show revision marks as underlining and 
strikethrough. The Text to Tracking Button converts the underlining and strikethrough in a document back 
into Microsoft Word revision marks (“Tracking”). The revision data associated with the changes will be 
that of the user at the time the Text to Tracking Button is pressed. 

MISC GROUP 

 
The Misc Group provides useful features that may be helpful during the Rule Drafting process.  This 
functionality is discussed below: 
Draft View Button 
The Draft View button displays the document in draft view. Draft view shows text formatting but 
simplifies the layout of the page so that you can type and edit quickly. In draft view, some page elements 
do not appear, such as the boundaries between pages, headers and footers, backgrounds, and pictures. 
Draft view is most useful when working with styles because the style associated with each paragraph is 
shown on the left side of the document. 

 
Print Layout Button 
The Print Layout button displays the document in print layout view. The print layout view displays the 
document as it appears on the printed page. Print layout view is the default view when you open a new 
document. 
Split Rule Button 
It is often helpful to work on multiple rules in one document, but OAH requires that rules be filed as 
individual rule documents. The Split Rule Button divides the currently displayed document into individual 
rules. The utility uses the history note or authority line to determine where a rule ends. It uses the rule 
citation to name the individual rule document. Rule range documents will be created if there are multiple 
rule citations with only one history note (as is often the case for repealed rules). The original document 
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must be saved before you click the Split Rule button, and the document must contain more than one rule. 
The original document is not modified. 
Show/Hide (Paragraph Mark) Button 
Pressing the Show/Hide button allows the non-printing characters to be revealed or shown in a document. 
"Nonprinting characters" is Word's term for anything that takes up space or has a formatting function but 
does not appear on the printed page, including spaces, tabs, page, or paragraph breaks, etc. This button is 
primarily used to be able to identify formatting or spacing issues in word processing documents. This 
button allows the user to quickly show or hide these characters. 
WORKING WITH DOCUMENTS CREATED BEFORE THE TEMPLATE WAS AVAILABLE 

To take advantage of the features available in the OAH Agency Rules Template for documents that were 
in the Rulemaking Process prior to the implementation of the OAH Agency Rules Template, you must 
create a new document based on the Template and insert your existing document into the newly created 
document. Although copy and paste will work, we recommend that you use the insert feature to include 
the contents of existing documents into your documents. 
Create a New Document based on the OAH Agency Rules Template 
Double click on the Template Icon on the Desktop. A new document based on the template will be created.   
Insert existing Document 
Use the Insert Rule from File function described previously in this document to navigate to the location 
of your existing rule document and insert that document into your newly created Template based 
document. 
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Appendix A 
 

Attaching the OAH Agency Rules Template to an Existing Document 
 

The OAH Agency Rules Template documentation suggests storing the OAH template on your desktop.  This works great in a 
single user environment.  However, many Rulemaking Coordinators work in a collaborative environment. Each agency has 
their own recommendations and computer configurations.  That makes it difficult to recommend a solution that will work for 
all agencies.  The ideal setup in a multiuser environment would be to utilize Microsoft Words “WorkGroup” template feature.  
This requires that all user workstations have a single location specified as their “workgroup template location” and the OAH 
template be stored there.  This requires access to a common drive by all users and configuration of each user’s installation of 
Microsoft Word.  This may not be possible for all agencies. 
 
The biggest challenge in a multiuser environment is that when a document is opened, Word may not be able to correctly locate 
the OAH template since the template in not located consistently.  This is most common when Rulemaking documents are 
emailed among users. When a document created with the OAH template is emailed, the template will not be attached when it 
reaches the Recipient. 
 
To Work around this issue, we are suggesting the following possible approaches. 

• You can create a new document using the OAH template stored on your computer and insert the contents of the 
document you received into new document.  Save that document and begin working. 

• If you would prefer not to create a new document, we have documented two options that you can utilize to attach the 
OAH Agency Rules Template to your document. 

o You can Attach the OAH template to your document using the Word Menu. 
o You can create a Macro and add the Macro to your Quick Access Toolbar. 

These two options are described below. 
 
NOTE: The OAH Agency Rules Template should only be used on documents that you know were 
originally created using the OAH Agency Rules Template.  Attaching the template to a document that 
was not created using the OAH Agency Template will most likely result in repeated errors being displayed 
while attempting to work on the document.  
 
 

Attaching the OAH Template to your Document using the Word Menu 
Enable the Developer Tab on the Word Ribbon 

You must first enable the Developer tab on the Word Ribbon before you can access the Template menu item in 
Microsoft Word. The following steps only have to be performed once. After you have enabled the Developer Tab, you 
can go straight to the Attach Template instructions below. Enabling the Developer Tab is accomplished as follows: 

1. Click on File on the Word Ribbon 

 
  

Click File 
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2. The File Menu will be displayed.  Select Options. 

 
 

3. The Word Options Menu will be displayed.  Click Customize Ribbon. 

 
4. The Customize “The Ribbon and Keyboard Shortcuts window” will be displayed. Put a Checkmark in the Developer 

box in the right-hand list box and click OK. You will now have the Developer Tab on your Word Toolbar. 

  

Click Options 

Click 

Check Mark in Developer Box 
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Attach the OAH Agency Rule Template to your Document 
1. After you have access to the Developer Tab, attaching the OAH template is straight forward. You click on the 

Developer tab and click the Document Template Button. 

 
2. After you have access to the Developer Tab, attaching the OAH template is straight forward. You click on the 

Developer tab and click the Document Template Button.  The “Templates and Add-ins” window will be displayed. 
On that window, click the Attach Button. 

 
3. The “Attach Template” window will be displayed. Navigate to the location on your computer where the document is 

stored and select the OAH Agency Rules Template.  Click Open. 

 
4. Click on the OK button when the “Templates and Add-Ins” window is displayed.  The OAH template is now 

attached to your document, and you should see the OAH tab on the Microsoft Word window. 

  

Click 

Click 

Click 

Select 
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Creating a Macro to Attach the OAH Template to your Document 
1. Open Word with a Blank Document 
2. Click on the View Tab 
3. Click on the Macros Button 
4. Click on the View Macros Menu Item 

 
5. After Clicking the View Macros Menu Item, the Macros window will be displayed. 

a. Type AttachTemplate in the Macro name filed (No spaces) 
b. Click the Create Button 

 
6. After Clicking the Create Button the New Macros Window will be displayed: 

 
7. Copy or Type the following text into the macro as show above: 

ActiveDocument.AttachedTemplate = "YOUR FILE LOCATION" & "OAH Agency Rules Template.dotm" 

Replace YOUR FILE LOCATION with the file location where you stored the template. For example, 
S:\Template\ 
You must have a backslash at the end of the file location. 

8. Click the X to Close the New Macros Window. You have now created the macro that will attach the OAH template 
to your document.  

  

View Tab 

View Macros 

Create Button 

Type Here 

Type or Paste Macro Text Here 

Click X to close Macro 
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9. The next step is to add the macro to Words Quick Access Toolbar so that it will be easily available to you. Click on 
the Customize Quick Access Toolbar Drop Down arrow on the right side of your Quick Access Toolbar: 

 
10. The Customize Quick Access Toolbar menu will be displayed. Click More Commands. 

 
11. The Word Options Menu will be displayed: 

a. Click the More Commands Drop Down and Select Macros 
b. Click on the Attached Template Macro in the left-hand list box and click the Add Button. The macro will 

be added to the right-hand list box. Click the OK button to close the Word Options Window. 

 
12. The Macro will now be displayed on your Quick access toolbar. If you do not see the OAH tab on your Word 

Toolbar, you can click the Macro Icon on your tool bar and the OAH template will be attached, and the toolbar will 
be visible. 

 

Quick Access Toolbar 

Click 

Click 

Use Dropdown to select Macros 

Select 
Macro 
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APPENDIX B – Rule Formatting 
There are three ways to format a rule. The format options are: 

1. Subdivided from the beginning 
2. Introductory paragraph with a listing 
3. Single paragraph 

The History Note will be formatted a little differently than the rule itself. 
 
NOTE: There are several styles that have been retired.  These styles are only valid for existing rules that already 
contain these styles.  They are SubPart, SubsubPart, SubItem Lvl 3, and SubItem Lvl 4.  These styles are noted 
with (HISTORICAL USE ONLY) in the tables below. 
 
The following tables provide formatting details for each rule style and the History Note: 

If a Rule is Subdivided from the Beginning, Use this Sequence: 

Style Rule Text 
Rule 01 NCAC 01 .1111 RULE NAME AND NUMBER IN BOLD AND ALL CAPS 
Paragraph (a)  This level in a rule is a Paragraph. You do not skip a line between the rule name/number 

and the beginning of this Paragraph. After typing the letter in parenthesis, it is followed with 2 
spaces. The first level of a rule (Paragraph) is the only time in a rule that the item in parenthesis 
is followed by 2 spaces instead of an tab. 

Subparagraph 
 

(1) This level in a rule is a Subparagraph. You do not skip a line between the 
Paragraph and Subparagraph. After typing the number in parenthesis, it is 
followed with 1 tab. 

(2) Remember – Any new level of a rule must have at least two items to create 
another subdivision. 

Part (A) This level in a rule is a Part. You do not skip a line between the 
Subparagraph and Part. After typing the letter in parenthesis, it is 
followed with 1 tab. 

SubPart (i) This level in a rule is a SubPart. (HISTORICAL RULES ONLY) 
SubsubPart (I) This level in a rule is a SubPart. (HISTORICAL RULES 

ONLY) 
Paragraph (b)  Return to the left margin for the next Paragraph. The text is flush with the left margin and 

no lines are skipped between the different sections of the rule. The parenthesis is followed by 
two spaces. 

If a Rule Contains an Introductory Paragraph with a Listing, Use this Sequence: 

Style Rule Text 
Rule 01 NCAC 02 .1111 RULE NAME AND NUMBER IN BOLD AND ALL CAPS 
Paragraph The opening paragraph is formatted with the text flush to the left margin and each consecutive 

line will wrap around to the left margin as shown here. 
Item 
 

(1) The first level in this type of format is called an Item. After typing the number in 
parenthesis, it is followed with 1 tab. 

(2) Remember – Any new level of a rule must have at least two items to create 
another subdivision. 

SubItem Lvl 1 (a) This next level in formatting this way is a Sub-Item. You do not skip a 
line between the Item and Sub-Item. After typing the letter in parenthesis, 
it is followed with 1 tab. 

SubItem Lvl 2 (i) This level in a rule is also called a Sub-Item. You do not skip a 
line between the different levels of Sub-Items. After typing the 
letter in parenthesis, it is followed with 1 tab. 

SubItem Lvl 3 (A) This level in a rule is also called a Sub-Item. 
(HISTORICAL RULES ONLY) 

SubItem Lvl 4 (I) This level in a rule is also called a Sub-Item. 
(HISTORICAL RULES ONLY) 
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If a Rule Contains a Single Paragraph, Use this Format: 

Style Rule Text 
Rule 01 NCAC 03 .1111 RULE NAME AND NUMBER IN BOLD AND ALL CAPS 
Paragraph A rule can be a single paragraph. Do not skip a line between the rule name/number and the first 

line of the paragraph. There are no subdivisions in this type of formatting. 

 
History Note Format: 

Style Rule Text 
History History Note: Authority [list in numerical order the citations to the agency's authority for the 

rule; all citations are separated by a semicolon; and the last citation also ends 
with a semicolon]; 

HistoryAfter Eff. [this is the effective date of the original adoption of the rule]; 
HistoryAfter Amended Eff. [these are amendment dates to the rule and shall be listed in 

chronological order, with the most recent amended date listed first]; 
HistoryAfter Temporary [Adoption][Amendment][Repeal] Eff. [Temporary rules are listed as 

a separate item]; 
HistoryAfter Repealed Eff. [If an agency deletes the rule in its entirety, this is a repeal. This 

rule number and history note can never be used again. 
NOTE: The most current effective date which is on the last line of the History Note, must be 

underlined completely if it is a new rule and if it is an adoption or repeal, then the new 
date must be the first shown and underlined 

 

Miscellaneous Format: 

Style Rule Text 
Chapter CHAPTER 01 - RULE CHAPTER NAME 

(Should always appear at the top of the first rule in a Chapter) 
SubChapter SUBCHAPTER 01A – RULE SUBCHAPTER NAME 

(Should always appear at the top of the first rule in a SubChapter) 
Section SECTION .0100 – RULE SECTION NAME 

(Should always appear at the top of the first rule in a Section) 
Base The Base style should be applied to any paragraph that does not meet the other styling 

guidelines outlined in the document. The Base style is generally applied to blank lines, tables, 
and forms.  
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